{
  "_links": {
    "capec": {
      "href": "/api/v1/vulnerability/cve-2024-32114/capec"
    },
    "cvss": {
      "href": "/api/v1/vulnerability/cve-2024-32114/cvss"
    },
    "cwe": {
      "href": "/api/v1/vulnerability/cve-2024-32114/cwe"
    },
    "enrichment": {
      "href": "/api/v1/vulnerability/cve-2024-32114/enrichment"
    },
    "gcve": {
      "href": "/api/v1/vulnerability/cve-2024-32114/gcve"
    },
    "self": {
      "href": "/api/v1/vulnerability/cve-2024-32114/enrichment"
    },
    "sightings": {
      "href": "/api/v1/sightings/cve-2024-32114"
    },
    "vulnerability": {
      "href": "/api/v1/vulnerability/cve-2024-32114"
    }
  },
  "enrichments": {
    "nuclei": {
      "nuclei": true,
      "nuclei_template": "http/cves/2024/CVE-2024-32114.yaml",
      "nuclei_template_severity": "high",
      "nuclei_template_yaml": "id: CVE-2024-32114\n\ninfo:\n  name: Apache ActiveMQ 6.x < 6.1.2 - Broken Access Control\n  author: ChrisJr404\n  severity: high\n  description: |\n    Apache ActiveMQ 6.x contains an unauthenticated API web context caused by default configuration lacking security measures in the Jetty server, letting anyone interact with broker APIs and messaging layers, exploit requires no authentication.\n  impact: |\n    Unauthenticated users can interact with the broker, potentially producing, consuming, or deleting messages and accessing sensitive management APIs.\n  remediation: |\n    Upgrade to Apache ActiveMQ 6.1.2 or later, or update `conf/jetty.xml` to require authentication on the `/api/` web context.\n  reference:\n    - https://activemq.apache.org/security-advisories.data/CVE-2024-32114-announcement.txt\n    - https://github.com/vulhub/vulhub/tree/master/activemq/CVE-2024-32114\n    - https://github.com/advisories/GHSA-gj5m-m88j-v7c3\n    - https://nvd.nist.gov/vuln/detail/CVE-2024-32114\n  classification:\n    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H\n    cvss-score: 8.8\n    cve-id: CVE-2024-32114\n    cwe-id: CWE-1188\n    epss-score: 0.07148\n    epss-percentile: 0.94297\n  metadata:\n    verified: true\n    max-request: 2\n    vendor: apache\n    product: activemq\n    shodan-query: http.title:\"ActiveMQ\"\n    fofa-query: title=\"ActiveMQ\"\n  tags: cve,cve2024,activemq,apache,jolokia,vkev\n\nhttp:\n  - method: GET\n    path:\n      - \"{{BaseURL}}/api/jolokia/search/org.apache.activemq:type=Broker,*\"\n\n    matchers:\n      - type: dsl\n        dsl:\n          - 'contains_all(body, \"request\\\":{\", \"type=Broker\", \"mbean\\\":\", \"org.apache.activemq\")'\n          - 'contains(content_type, \"text/plain\")'\n          - 'status_code == 200'\n        condition: and\n# digest: 4a0a004730450220270418b5d41a750102b093b92c7302afe25f70f30ab13deb728262028c006fb3022100846a1e3f8078a1873c441ed81a15f9eb45ff9db760fe376f6746b0845baf9ec1:922c64590222798bb761d5b6d8e72950"
    }
  },
  "vuln_id": "cve-2024-32114"
}