{
  "cvss": 0.0,
  "datePublished": "2026-04-01T00:00:00Z",
  "dateUpdated": "2026-04-01T00:00:00Z",
  "description": "Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.",
  "dueDate": "",
  "id": "CVE-2026-27971",
  "kev_catalogs": [
    "vulncheck"
  ],
  "knownRansomwareCampaignUse": "Unknown",
  "product": "qwik",
  "requiredAction": "Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.",
  "severity": "HIGH",
  "source": "vulncheck_kev",
  "title": "qwik qwik Deserialization of Untrusted Data",
  "vendor": "qwik"
}