cve-2025-61188
MEDIUM CVSS 6.3 nvd
Description
Jeecgboot versions 3.8.2 and earlier are affected by a path traversal vulnerability. This vulnerability allows attackers to upload files with system-whitelisted extensions to the system directory /opt, instead of the /opt/upFiles directory specified by the web server.
Timeline
- Published
- 2025-10-01
- Last Modified
- 2026-11-05
CVSS Details
- Attack Vector
- NETWORK
- Attack Complexity
- LOW
- Privileges Required
- NONE
Affected Products
- jeecg jeecg_boot
Weaknesses (CWE)
CVSS metrics
| Version | Base | Severity | Vector | Exploitability | Impact | Source |
|---|---|---|---|---|---|---|
| 3.1 | 6.3 | MEDIUM | CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L |
2.8 | 3.4 | 134c704f-9b21-4f2e-91b3-4a467353bcc0 |
CPE configurations
OR
| CPE | Version range | Vulnerable |
|---|---|---|
cpe:2.3:a:jeecg:jeecg_boot:*:*:*:*:*:*:*:* |
<= 3.8.2 | yes |
NVD metadata
- NVD status
- Analyzed
- Source identifier
cve@mitre.org
References
- https://github.com/jeecgboot/JeecgBoot/issues/8826 Exploit, Issue Tracking, Vendor Advisory
Linked Vulnerabilities
No linked vulnerabilities found.
{
"cvss": 6.3,
"datePublished": "2025-10-01T20:18:38.980",
"dateUpdated": "2026-11-05T23:10:00.150",
"description": "Jeecgboot versions 3.8.2 and earlier are affected by a path traversal vulnerability. This vulnerability allows attackers to upload files with system-whitelisted extensions to the system directory /opt, instead of the /opt/upFiles directory specified by the web server.",
"id": "CVE-2025-61188",
"raw": {
"affected": [
{
"affectedData": [
{
"product": "n/a",
"vendor": "n/a",
"versions": [
{
"status": "affected",
"version": "n/a"
}
]
}
],
"source": "cve@mitre.org"
}
],
"configurations": [
{
"nodes": [
{
"cpeMatch": [
{
"criteria": "cpe:2.3:a:jeecg:jeecg_boot:*:*:*:*:*:*:*:*",
"matchCriteriaId": "5D9554A8-0B05-4ADC-B01D-9ED87EB7D776",
"versionEndIncluding": "3.8.2",
"vulnerable": true
}
],
"negate": false,
"operator": "OR"
}
]
}
],
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Jeecgboot versions 3.8.2 and earlier are affected by a path traversal vulnerability. This vulnerability allows attackers to upload files with system-whitelisted extensions to the system directory /opt, instead of the /opt/upFiles directory specified by the web server."
},
{
"lang": "es",
"value": "Las versiones 3.8.2 y anteriores de Jeecgboot están afectadas por una vulnerabilidad de salto de ruta. Esta vulnerabilidad permite a los atacantes cargar archivos con extensiones permitidas por el sistema al directorio del sistema /opt, en lugar del directorio /opt/upFiles especificado por el servidor web."
}
],
"id": "CVE-2025-61188",
"lastModified": "2026-11-05T23:10:00.150",
"metrics": {
"cvssMetricV31": [
{
"cvssData": {
"attackComplexity": "LOW",
"attackVector": "NETWORK",
"availabilityImpact": "LOW",
"baseScore": 6.3,
"baseSeverity": "MEDIUM",
"confidentialityImpact": "LOW",
"integrityImpact": "LOW",
"privilegesRequired": "NONE",
"scope": "UNCHANGED",
"userInteraction": "REQUIRED",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L",
"version": "3.1"
},
"exploitabilityScore": 2.8,
"impactScore": 3.4,
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary"
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"id": "CVE-2025-61188",
"options": [
{
"exploitation": "poc"
},
{
"automatable": "no"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"timestamp": "2025-10-01T20:18:45.823887Z",
"version": "2.0.3"
}
}
]
},
"published": "2025-10-01T20:18:38.980",
"references": [
{
"source": "cve@mitre.org",
"tags": [
"Exploit",
"Issue Tracking",
"Vendor Advisory"
],
"url": "https://github.com/jeecgboot/JeecgBoot/issues/8826"
}
],
"sourceIdentifier": "cve@mitre.org",
"vulnStatus": "Analyzed",
"weaknesses": [
{
"description": [
{
"lang": "en",
"value": "CWE-24"
}
],
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary"
}
]
},
"severity": "MEDIUM",
"source": "nvd",
"title": "Jeecgboot versions 3.8.2 and earlier are affected by a path traversal vulnerability"
}