cve-2025-68493
HIGH vulncheck_kev
Description
Missing XML Validation vulnerability in Apache Struts, Apache Struts. This issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0. Users are recommended to upgrade to version 6.1.1, which fixes the issue.
Timeline
- Published
- 2026-07-20 00:00 UTC
- Last Modified
- 2026-07-20
CVSS Details
CVSS details not available.
Affected Products
No product information available.
References
No references available.
Linked Vulnerabilities
No linked vulnerabilities found.
{
"cvss": 0.0,
"datePublished": "2026-07-20T00:00:00Z",
"dateUpdated": "2026-07-20T00:00:00Z",
"description": "Missing XML Validation vulnerability in Apache Struts, Apache Struts.\n\nThis issue affects Apache Struts: from 2.0.0 before 2.2.1; Apache Struts: from 2.2.1 through 6.1.0.\n\nUsers are recommended to upgrade to version 6.1.1, which fixes the issue.",
"dueDate": "",
"id": "CVE-2025-68493",
"kev_catalogs": [
"vulncheck"
],
"knownRansomwareCampaignUse": "Unknown",
"product": "Struts",
"requiredAction": "Apply remediations or mitigations per vendor instructions or discontinue use of the product if remediation or mitigations are unavailable.",
"severity": "HIGH",
"source": "vulncheck_kev",
"title": "Apache Struts Improper Restriction of XML External Entity Reference",
"vendor": "Apache"
}
Enrichment data
Aggregated bundle (all enrichments)