cve-2026-32327
CRITICAL CVSS 9.1 nvd
Description
A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function. Users are recommended to upgrade to version 1.6.4, which fixes this issue.
Timeline
- Published
- 2026-08-06
- Last Modified
- 2026-10-24
CVSS Details
- Attack Vector
- NETWORK
- Attack Complexity
- LOW
- Privileges Required
- NONE
Affected Products
- apache apr-util
Weaknesses (CWE)
CVSS metrics
| Version | Base | Severity | Vector | Exploitability | Impact | Source |
|---|---|---|---|---|---|---|
| 3.1 | 9.1 | CRITICAL | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H |
3.9 | 5.2 | 134c704f-9b21-4f2e-91b3-4a467353bcc0 |
CPE configurations
OR
| CPE | Version range | Vulnerable |
|---|---|---|
cpe:2.3:a:apache:apr-util:*:*:*:*:*:*:*:* |
< 1.6.4 | yes |
NVD metadata
- NVD status
- Analyzed
- Source identifier
security@apache.org
References
- https://lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/06/9 Mailing List, Third Party Advisory
Linked Vulnerabilities
{
"cvss": 9.1,
"datePublished": "2026-08-06T15:16:54.190",
"dateUpdated": "2026-10-24T16:10:00.153",
"description": "A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function.\n\nUsers are recommended to upgrade to version 1.6.4, which fixes this issue.",
"id": "CVE-2026-32327",
"raw": {
"affected": [
{
"affectedData": [
{
"defaultStatus": "unaffected",
"packageName": "APR-util",
"product": "Apache Portable Runtime Utility",
"vendor": "Apache Software Foundation",
"versions": [
{
"lessThanOrEqual": "1.6.3",
"status": "affected",
"version": "0",
"versionType": "semver"
}
]
}
],
"source": "security@apache.org"
}
],
"configurations": [
{
"nodes": [
{
"cpeMatch": [
{
"criteria": "cpe:2.3:a:apache:apr-util:*:*:*:*:*:*:*:*",
"matchCriteriaId": "92873888-3F9F-45E0-930E-D06B5648DC2C",
"versionEndExcluding": "1.6.4",
"vulnerable": true
}
],
"negate": false,
"operator": "OR"
}
]
}
],
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function.\n\nUsers are recommended to upgrade to version 1.6.4, which fixes this issue."
},
{
"lang": "es",
"value": "Un error en APR-util versión 1.6.3 (y anteriores) permite un ataque de recursión de pila contra cualquier consumidor de biblioteca que analiza XML de fuentes no confiables y utiliza la función apr_xml_quote_elem().\n\nSe recomienda a los usuarios actualizar a la versión 1.6.4, que corrige este problema."
}
],
"id": "CVE-2026-32327",
"lastModified": "2026-10-24T16:10:00.153",
"metrics": {
"cvssMetricV31": [
{
"cvssData": {
"attackComplexity": "LOW",
"attackVector": "NETWORK",
"availabilityImpact": "HIGH",
"baseScore": 9.1,
"baseSeverity": "CRITICAL",
"confidentialityImpact": "HIGH",
"integrityImpact": "NONE",
"privilegesRequired": "NONE",
"scope": "UNCHANGED",
"userInteraction": "NONE",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H",
"version": "3.1"
},
"exploitabilityScore": 3.9,
"impactScore": 5.2,
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary"
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"id": "CVE-2026-32327",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "partial"
}
],
"role": "CISA Coordinator",
"timestamp": "2026-08-06T17:46:05.943190Z",
"version": "2.0.3"
}
}
]
},
"published": "2026-08-06T15:16:54.190",
"references": [
{
"source": "security@apache.org",
"tags": [
"Mailing List",
"Vendor Advisory"
],
"url": "https://lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1"
},
{
"source": "af854a3a-2127-422b-91ae-364da2661108",
"tags": [
"Mailing List",
"Third Party Advisory"
],
"url": "http://www.openwall.com/lists/oss-security/2026/08/06/9"
}
],
"sourceIdentifier": "security@apache.org",
"vulnStatus": "Analyzed",
"weaknesses": [
{
"description": [
{
"lang": "en",
"value": "CWE-674"
}
],
"source": "security@apache.org",
"type": "Secondary"
}
]
},
"severity": "CRITICAL",
"source": "nvd",
"title": "A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which pars..."
}