cve-2026-55957
HIGH CVSS 7.3 nvd
Description
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Timeline
- Published
- 2026-06-29
- Last Modified
- 2026-10-25
CVSS Details
- Attack Vector
- NETWORK
- Attack Complexity
- LOW
- Privileges Required
- NONE
Affected Products
- apache tomcat
Weaknesses (CWE)
CVSS metrics
| Version | Base | Severity | Vector | Exploitability | Impact | Source |
|---|---|---|---|---|---|---|
| 3.1 | 7.3 | HIGH | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L |
3.9 | 3.4 | 134c704f-9b21-4f2e-91b3-4a467353bcc0 |
CPE configurations
OR
| CPE | Version range | Vulnerable |
|---|---|---|
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* |
< 9.0.101 | yes |
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* |
>= 10.1.0, < 10.1.37 | yes |
cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:* |
>= 11.0.0, < 11.0.5 | yes |
NVD metadata
- NVD status
- Analyzed
- Source identifier
security@apache.org
References
- https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh Vendor Advisory, Mailing List
- http://www.openwall.com/lists/oss-security/2026/06/29/26 Third Party Advisory
Linked Vulnerabilities
{
"cvss": 7.3,
"datePublished": "2026-06-29T21:16:45.700",
"dateUpdated": "2026-10-25T21:10:00.770",
"description": "Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.\n\nUsers are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.",
"id": "CVE-2026-55957",
"raw": {
"affected": [
{
"affectedData": [
{
"defaultStatus": "unaffected",
"product": "Apache Tomcat",
"vendor": "Apache Software Foundation",
"versions": [
{
"lessThanOrEqual": "11.0.4",
"status": "affected",
"version": "11.0.0-M1",
"versionType": "semver"
},
{
"lessThanOrEqual": "10.1.36",
"status": "affected",
"version": "10.1.0-M1",
"versionType": "semver"
},
{
"lessThanOrEqual": "9.0.100",
"status": "affected",
"version": "9.0.0.M1",
"versionType": "semver"
},
{
"lessThanOrEqual": "8.5.100",
"status": "affected",
"version": "8.5.0",
"versionType": "semver"
},
{
"lessThanOrEqual": "7.0.109",
"status": "affected",
"version": "7.0.0",
"versionType": "semver"
},
{
"lessThan": "7.0.0",
"status": "unknown",
"version": "0",
"versionType": "semver"
}
]
}
],
"source": "security@apache.org"
}
],
"configurations": [
{
"nodes": [
{
"cpeMatch": [
{
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"matchCriteriaId": "BE6699B4-1EA4-43C1-A0E2-76BBFD4E90CD",
"versionEndExcluding": "9.0.101",
"vulnerable": true
},
{
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"matchCriteriaId": "8BF69915-915D-44CA-9027-206E44B89B78",
"versionEndExcluding": "10.1.37",
"versionStartIncluding": "10.1.0",
"vulnerable": true
},
{
"criteria": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
"matchCriteriaId": "0EF54F3C-5527-44DB-AAD0-109A081A742B",
"versionEndExcluding": "11.0.5",
"versionStartIncluding": "11.0.0",
"vulnerable": true
}
],
"negate": false,
"operator": "OR"
}
]
}
],
"cveTags": [],
"descriptions": [
{
"lang": "en",
"value": "Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.\n\nThis issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.\n\nUsers are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue."
},
{
"lang": "es",
"value": "Vulnerabilidad de Paso Crítico Faltante en la Autenticación en Apache Tomcat cuando el JNDIRealm estaba configurado para autenticar enlaces usando GSSAPI permitió a los atacantes autenticarse sin proporcionar la contraseña correcta.\n\nEste problema afecta a Apache Tomcat: desde 11.0.0-M1 hasta 11.0.4, desde 10.1.0-M1 hasta 10.1.36, desde 9.0.0.M1 hasta 9.0.100, desde 8.5.0 hasta 8.5.100, desde 7.0.0 hasta 7.0.109.\n\nSe recomienda a los usuarios actualizar a la versión 11.0.5, 10.1.37 o 9.0.101, que corrige el problema."
}
],
"id": "CVE-2026-55957",
"lastModified": "2026-10-25T21:10:00.770",
"metrics": {
"cvssMetricV31": [
{
"cvssData": {
"attackComplexity": "LOW",
"attackVector": "NETWORK",
"availabilityImpact": "LOW",
"baseScore": 7.3,
"baseSeverity": "HIGH",
"confidentialityImpact": "LOW",
"integrityImpact": "LOW",
"privilegesRequired": "NONE",
"scope": "UNCHANGED",
"userInteraction": "NONE",
"vectorString": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L",
"version": "3.1"
},
"exploitabilityScore": 3.9,
"impactScore": 3.4,
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"type": "Secondary"
}
],
"ssvcV203": [
{
"source": "134c704f-9b21-4f2e-91b3-4a467353bcc0",
"ssvcData": {
"id": "CVE-2026-55957",
"options": [
{
"exploitation": "none"
},
{
"automatable": "yes"
},
{
"technicalImpact": "total"
}
],
"role": "CISA Coordinator",
"timestamp": "2026-06-30T13:26:38.087999Z",
"version": "2.0.3"
}
}
]
},
"published": "2026-06-29T21:16:45.700",
"references": [
{
"source": "security@apache.org",
"tags": [
"Vendor Advisory",
"Mailing List"
],
"url": "https://lists.apache.org/thread/7fk339o5jvd4mcgsf0chbrn4o525ccjh"
},
{
"source": "af854a3a-2127-422b-91ae-364da2661108",
"tags": [
"Third Party Advisory"
],
"url": "http://www.openwall.com/lists/oss-security/2026/06/29/26"
}
],
"sourceIdentifier": "security@apache.org",
"vulnStatus": "Analyzed",
"weaknesses": [
{
"description": [
{
"lang": "en",
"value": "CWE-304"
}
],
"source": "security@apache.org",
"type": "Secondary"
}
]
},
"severity": "HIGH",
"source": "nvd",
"title": "Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authentic..."
}