drupal-contrib-2026-311
osv_packagist
Description
This module integrates the Site Catalyst or AdobeAnalytics software into a Drupal site. The module does not sufficiently provide access controls for advanced functionality, which exposes a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have permission to add or edit content that is configured to use the module's functionality.
Timeline
- Published
- unknown
- Last Modified
- unknown
CVSS Details
CVSS details not available.
Affected Products
No product information available.
References
Linked Vulnerabilities
No linked vulnerabilities found.
{
"affected": [
{
"database_specific": {
"affected_versions": "<1.1.0",
"source": "https://github.com/DrupalSecurityTeam/drupal-advisory-database/blob/main/advisories/adobe_analytics/DRUPAL-CONTRIB-2026-311.json"
},
"package": {
"ecosystem": "Packagist:https://packages.drupal.org/8",
"name": "drupal/adobe_analytics",
"purl": "pkg:composer/drupal/adobe_analytics?repository_url=https:%2F%2Fpackages.drupal.org%2F8"
},
"ranges": [
{
"database_specific": {
"constraint": "<1.1.0"
},
"events": [
{
"introduced": "0"
},
{
"fixed": "1.1.0"
}
],
"type": "ECOSYSTEM"
}
]
}
],
"aliases": [
"CVE-2026-122083"
],
"credits": [
{
"contact": [
"https://www.drupal.org/u/nodles"
],
"name": "Francisco Javier Rodriguez (nodles)"
}
],
"details": "This module integrates the Site Catalyst or AdobeAnalytics software into a Drupal site.\n\nThe module does not sufficiently provide access controls for advanced functionality, which exposes a cross-site scripting (XSS) vulnerability.\n\nThis vulnerability is mitigated by the fact that an attacker must have permission to add or edit content that is configured to use the module's functionality.",
"id": "DRUPAL-CONTRIB-2026-311",
"modified": "2026-11-04T20:30:02.730227971Z",
"published": "2026-11-04T17:51:39Z",
"references": [
{
"type": "WEB",
"url": "https://www.drupal.org/sa-contrib-2026-311"
}
],
"schema_version": "1.9.2"
}