drupal-contrib-2026-315

osv_packagist
Description

The htmLawed module enables use of the [htmLawed](https://bioinformatics.org/phplabware/internal_utilities/htmLawed/index.php "htmLawed website") PHP library as a filter in a Text Format for restriction/filtering of HTML in textual input. The htmLawed filter does not sufficiently filter attributes, leading to a cross-site scripting (XSS) vulnerability. This vulnerability affects sites on Drupal core > 11.2 or any version of core with the HTMX library.

Timeline
Published
unknown
Last Modified
unknown
CVSS Details

CVSS details not available.

Affected Products

No product information available.

References
Linked Vulnerabilities

No linked vulnerabilities found.

{
  "affected": [
    {
      "database_specific": {
        "affected_versions": ">=4.1.0 <4.1.11",
        "source": "https://github.com/DrupalSecurityTeam/drupal-advisory-database/blob/main/advisories/htmlawed/DRUPAL-CONTRIB-2026-315.json"
      },
      "package": {
        "ecosystem": "Packagist:https://packages.drupal.org/8",
        "name": "drupal/htmlawed",
        "purl": "pkg:composer/drupal/htmlawed?repository_url=https:%2F%2Fpackages.drupal.org%2F8"
      },
      "ranges": [
        {
          "database_specific": {
            "constraint": ">=4.1.0 <4.1.11"
          },
          "events": [
            {
              "introduced": "4.1.0"
            },
            {
              "fixed": "4.1.11"
            }
          ],
          "type": "ECOSYSTEM"
        }
      ]
    }
  ],
  "aliases": [
    "CVE-2026-122079"
  ],
  "credits": [
    {
      "contact": [
        "https://www.drupal.org/u/prudloff"
      ],
      "name": "Pierre Rudloff (prudloff)"
    }
  ],
  "details": "The htmLawed module enables use of the [htmLawed](https://bioinformatics.org/phplabware/internal_utilities/htmLawed/index.php \"htmLawed website\") PHP library as a filter in a Text Format for restriction/filtering of HTML in textual input.\n\nThe htmLawed filter does not sufficiently filter attributes, leading to a cross-site scripting (XSS) vulnerability.\n\nThis vulnerability affects sites on Drupal core > 11.2 or any version of core with the HTMX library.",
  "id": "DRUPAL-CONTRIB-2026-315",
  "modified": "2026-11-04T20:30:03.553450737Z",
  "published": "2026-11-04T17:52:43Z",
  "references": [
    {
      "type": "WEB",
      "url": "https://www.drupal.org/sa-contrib-2026-315"
    }
  ],
  "schema_version": "1.9.2"
}
View JSON API Download JSON