ubuntu-cve-2025-46337
CVSS 10.0 osv_ubuntu
Description
ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.
Timeline
- Published
- unknown
- Last Modified
- unknown
CVSS Details
CVSS details not available.
Affected Products
No product information available.
References
- https://ubuntu.com/security/CVE-2025-46337
- https://www.cve.org/CVERecord?id=CVE-2025-46337
- https://github.com/ADOdb/ADOdb/security/advisories/GHSA-8x27-jwjr-8545
- https://github.com/ADOdb/ADOdb/issues/1070
- https://github.com/ADOdb/ADOdb/commit/11107d6d6e5160b62e05dff8a3a2678cf0e3a426
- https://ubuntu.com/security/notices/USN-7530-1
- https://ubuntu.com/security/notices/USN-7530-2
Linked Vulnerabilities
No linked vulnerabilities found.
{
"affected": [
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.20.3-1ubuntu1+esm2"
}
]
},
"package": {
"ecosystem": "Ubuntu:Pro:16.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Fxenial"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.3-1ubuntu1+esm2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.18a-1",
"5.20.1-1",
"5.20.2-1",
"5.20.2-2",
"5.20.3-1",
"5.20.3-1ubuntu1",
"5.20.3-1ubuntu1+esm1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.20.9-1ubuntu0.1~esm2"
}
]
},
"package": {
"ecosystem": "Ubuntu:Pro:18.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Fbionic"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.9-1ubuntu0.1~esm2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.20.9-1",
"5.20.9-1ubuntu0.1~esm1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.20.16-1ubuntu0.1~esm2"
}
]
},
"package": {
"ecosystem": "Ubuntu:Pro:20.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Ffocal"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.16-1ubuntu0.1~esm2"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.20.14-1",
"5.20.15-1",
"5.20.16-1",
"5.20.16-1ubuntu0.1~esm1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.20.19-1ubuntu0.1+esm1"
}
]
},
"package": {
"ecosystem": "Ubuntu:Pro:22.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Fjammy"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.20.19-1ubuntu0.1+esm1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.20.19-1",
"5.20.19-1ubuntu0.1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.21.4-1ubuntu0.1~esm1"
}
]
},
"package": {
"ecosystem": "Ubuntu:Pro:24.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=esm-apps%2Fnoble"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.21.4-1ubuntu0.1~esm1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.21.4-1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "No subscription required",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.22.9-0.1"
}
]
},
"package": {
"ecosystem": "Ubuntu:25.10",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=questing"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.22.9-0.1"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"5.22.8-0.1"
]
},
{
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2025/UBUNTU-CVE-2025-46337.json"
},
"ecosystem_specific": {
"availability": "No subscription required",
"binaries": [
{
"binary_name": "libphp-adodb",
"binary_version": "5.22.9-0.1"
}
]
},
"package": {
"ecosystem": "Ubuntu:26.04:LTS",
"name": "libphp-adodb",
"purl": "pkg:deb/ubuntu/libphp-adodb?arch=source&distro=resolute"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "5.22.9-0.1"
}
],
"type": "ECOSYSTEM"
}
]
}
],
"details": "ADOdb is a PHP database class library that provides abstractions for performing queries and managing databases. Prior to version 5.22.9, improper escaping of a query parameter may allow an attacker to execute arbitrary SQL statements when the code using ADOdb connects to a PostgreSQL database and calls pg_insert_id() with user-supplied data. This issue has been patched in version 5.22.9.",
"id": "UBUNTU-CVE-2025-46337",
"modified": "2026-11-04T20:12:40.191675408Z",
"published": "2025-05-01T18:15:00Z",
"references": [
{
"type": "REPORT",
"url": "https://ubuntu.com/security/CVE-2025-46337"
},
{
"type": "REPORT",
"url": "https://www.cve.org/CVERecord?id=CVE-2025-46337"
},
{
"type": "REPORT",
"url": "https://github.com/ADOdb/ADOdb/security/advisories/GHSA-8x27-jwjr-8545"
},
{
"type": "REPORT",
"url": "https://github.com/ADOdb/ADOdb/issues/1070"
},
{
"type": "REPORT",
"url": "https://github.com/ADOdb/ADOdb/commit/11107d6d6e5160b62e05dff8a3a2678cf0e3a426"
},
{
"type": "REPORT",
"url": "https://github.com/ADOdb/ADOdb/commit/11107d6d6e5160b62e05dff8a3a2678cf0e3a426"
},
{
"type": "ADVISORY",
"url": "https://ubuntu.com/security/notices/USN-7530-1"
},
{
"type": "ADVISORY",
"url": "https://ubuntu.com/security/notices/USN-7530-2"
}
],
"related": [
"USN-7530-1",
"USN-7530-2"
],
"schema_version": "1.9.2",
"severity": [
{
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L",
"type": "CVSS_V3"
},
{
"score": "medium",
"type": "Ubuntu"
}
],
"upstream": [
"CVE-2025-46337"
]
}